zmamavisdctl restart

Muchas gracias a Manuel Oya por el consejo y recordatorio

Y esto es todo, ya tenemos nuestro flamante Zimbra Collaboration 8.7, actualizado desde la versión 8.6, con Proxy y memcached funcionando correctamente.

Ya solamente nos queda echar un vistazo a todas las novedades que Zimbra Collaboration 8.7 trae en esta versión.

Reader Interactions

Comments

  1. Rafael Montagud says

    Un problema que puede pasar después del upgrade: DSPAM está habilitado en amavis a pesar que zimbraAmavisDSPAMEnabled está como FALSE.
    No es nada divertido ver la cola de postfix con todos los mensajes atascados en el filtro de contenido, pero puede solucionarse comentando las líneas adecuadas

  2. David Moreira says

    Estimado Jorge, que buen aporte.

    Tengo una consulta con respecto a si estos estos comando hay que utilizarlos solo cuando se hace una actualización desde la version 8.6 a 8.7 o también se lo debe hacer si se instala el zimbra 8.7 por primera vez.

    zmprov mcf zimbraMtaCommandDirectory /opt/zimbra/common/sbin
    zmprov mcf zimbraMtaDaemonDirectory /opt/zimbra/common/libexec
    zmprov mcf zimbraMtaMailqPath /opt/zimbra/common/sbin/mailq
    zmprov mcf zimbraMtaManpageDirectory /opt/zimbra/common/share/man
    zmprov mcf zimbraMtaNewaliasesPath /opt/zimbra/common/sbin/newaliases
    zmprov mcf zimbraMtaSendmailPath /opt/zimbra/common/sbin/sendmail
    zmcontrol restart

    Gracias.
    David.

  3. Estuardo Luna says

    Buenas tardes, alguien puede ayudarme por favor. Tengo un problema con mi server zimbra, el problema es que los correos llegan con retraso o simplemente no llegan. Alguien tiene idea de que puedo revisar? para ver si hay algo mal configurado, etc.

    Gracias.

      • Estuardo Luna says

        El resultado que me dio fue este:

        https://www.mail-tester.com/web-YBHzrS

        Puntuacion 7/10. Si no me equivoco lo veo bien.

        Algunos correos me llegan, otros no, o llegan tarde. Tendra entre sus archivos alguna lista de comandos para revisar logs, o postfix etc.

        Para serle sincero soy bastante nuevo en este servicio. Gracias por su ayuda.

        • Jorge de la Cruz says

          Saludos,
          Veo que la IP se encuentra en reputación neutral, lo que hace que tengas problemas con ciertos destinatarios claro, la reputación debe estar en good, suele cambiar despues de un tiempo de tener un servidor de correo funcionando en una IP sin que se envíe SPAM, también ayuda tener SPF y DKIM configurado, te dejo aqui todos los links que tienes que seguir:
          http://www.senderbase.org/lookup/?search_string=209.124.97.34
          https://wiki.zimbra.com/wiki/Best_Practices_on_Email_Protection:_SPF,_DKIM_and_DMARC

          La puntuación debe ser 10/10 🙂

          Un saludo

          • Estuardo Luna says

            Gracias por su ayuda. Ahorita el server ya tiene 9/10 solo tengo una duda con el DKIM. En zimbra lo genere y me dio esto:

            (“v=DKIM1; k=rsa; ” “p=seriedenumeros”)

            Si lo ingreso asi en NetworkSolutions me dice que las ” ” no se deben usar. Entonces lo hice de la siguiente manera:

            v=DKIM1; k=rsa; p=seriedenumeros

            Aunque no se si es correcto.

            Luego de todos estos procesos, que mas puedo hacer? Ya que hoy algunos correos que mandaron hace 2 dias, hasta hoy ingresaron al inbox. Y unos correos de hace una semana nunca llegaron.

            Cuando hay casos como ese, que es recomendable hacer?

            Muchas gracias por la ayuda. Es el único lugar donde he encontrado soluciones.

          • Jorge de la Cruz says

            Saludos,
            Ahora solamente te queda esperar que senderbase ponga que tienes reputacion en good, no en neutral. Lo mejor en estos casos es usar un SMTP Relay de una empresa, por ejemplo Spam Experts permiten esto mismo.

            Un saludo

          • Estuardo Luna says

            Buenas tardes, hice todo lo indicado, pero aun así hay correos que nunca me llegan al zimbra, o llegan tarde.

            Me podrían ayudar indicándome que debo hacer para revisar este problema, o que podrá estar mal.

            Muchas gracias por su ayuda.

    • Jorge de la Cruz says

      Sin más logs que el adjunto en el foro de Zimbra, supongo que hubo algún problema con apt-get pero no te se indicar si en tu server o a nivel de Zimbra, parece que varias personas sufrieron la misma incidencia, quedaré atento.

      Un saludo

      • Pato says

        Jorge, gracias por responder. Fuimos avanzando con apt.
        Termina de bajar los servicios correctamente. El problema actual es con certificados ssl (geotrust) y pincha en ldap:

        Starting mysql…
        *** Running as zimbra user: /opt/zimbra/bin/mysql.server start
        Starting mysqld…done.
        done.
        Checking ldap status…
        *** Running as zimbra user: /opt/zimbra/bin/ldap status
        not running.
        Checking ldap status…
        *** Running as zimbra user: /opt/zimbra/bin/ldap status
        not running.

        Running as zimbra user: /opt/zimbra/bin/ldap start
        Failed to start slapd. Attempting debug start to determine error.
        TLS: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch x509_cmp.c:340
        57967c82 main: TLS init def ctx failed: -1
        failed with exit code: 256.
        UPGRADE FAILED – exiting.

        Gracias y saludos!

        • Jorge de la Cruz says

          Saludos,
          Prueba estos pasos y dime si funciona:
          $ /opt/zimbra/bin/zmcertmgr createca -new -newkey
          $ /opt/zimbra/bin/zmcertmgr createcrt -new -days 365
          $ /opt/zimbra/bin/zmcertmgr deploycrt self
          $ /opt/zimbra/bin/zmcertmgr deployca
          $ zmlocalconfig -e ssl_allow_untrusted_certs=true

          Y luego fuerza la instalación de nuevo:
          ./install.sh --force-upgrade --skip-activation-check --skip-upgrade-check

          • Pato says

            Cuando ejecuto la 2da línea (createcrt) me responde lo siguiente:
            ** Backup /opt/zimbra/ssl/zimbra to /opt/zimbra/ssl/zimbra.20160726104334
            ** Recreating /opt/zimbra/conf/zmssl.cnf
            ** Generating a server CSR of type ‘self’ for download
            ** Using CA cert in ‘/opt/zimbra/ssl/zimbra/ca/ca.pem’
            ** Using CA private key in ‘/opt/zimbra/ssl/zimbra/ca/ca.key’
            ** Retrieving Commercial CA cert from LDAP… failed
            ** Creating server cert request /opt/zimbra/ssl/zimbra/server/server.csr with keysize=2048 digest=sha256
            ** Saving config key ‘zimbraSSLPrivateKey’ via zmprov modifyServer xxxxx.xxxxx.com…failed (rc=1)
            ** Signing cert request /opt/zimbra/ssl/zimbra/server/server.csr

            Gracias!

  4. David Vilchez says

    Hola Jorge, te cuento que pude realizar la actualización de 8.6 a 8.7 y hasta el momento el único problema que tengo es que en las firmas de cada cuenta de correo de los usuarios está colocado el logo de la empresa pero luego de la actualización cuando los correos son enviados una vez que se reciben en la firma lo que se muestra es un enlace roto.
    Ve que en el foro de zimbra ya hay un caso así pero aún no tiene respuesta, será que a travez de tu experiencia puedes ayudarme a solucionar esta situación?
    Gracias!

  5. David Vilchez says

    Hola Jorge, después de la actualización estoy agregando una dirección de correo al whitelist desde el archivo salocal.cf.in y cuando reinicio servicio zmmtactl obtengo el siguiente mensaje:
    “postalias: fatal: open database /etc/aliases.lmdb: Permission denied” no se que puede ser, he buscado información al respecto pero no he encontrado nada.
    Cualquier ayuda al respecto te la agradeceré.

      • David Vilchez says

        Esto sucede al correr el comando: zmmtactl restart
        El resultado que obtengo es este:
        zimbra@mail:~$ zmmtactl restart
        Rewriting configuration files…done.
        Stopping saslauthd…done.
        Starting saslauthd…done.
        postalias: fatal: open database /etc/aliases.lmdb: Permission denied
        /postfix-script: refreshing the Postfix mail system
        zimbra@mail:~$

  6. Fernando says

    Hola Jorge,
    gracias por el post, me ha sido de gran ayuda. Solo comentar el siguiente detalle por si le pasa a alguien más. La actualización a Zimbra 8.7 se bloqueó cuando el script de instalación intentaba acceder al mariadb.

    Es un bug ya reportado y hay varios workarrounds:

    https://bugzilla.zimbra.com/show_bug.cgi?id=105942

    Me quedé con al solución sencilla de eliminar la entrada mysql_socket de /opt/zimbra/conf/localconfig.xml:

    ${zimbra_db_directory}/mysql.sock

    Un saludo.

      • Gabriel says

        Hola Jorge,
        Tenemos un servidor 8.6 con Patch 7, sobre Ubuntu 12.04.5 LTS.
        El error que comenta Fernando se presenta siempre?
        Cómo debo continuar en caso que se presente?
        Desde ya, muchas gracias!
        Saludos

        • Jorge de la Cruz says

          Saludos Gabriel,
          Es posible que suceda, es un poco complejo y puede haber problemas para hacer funcionar el servidor. Por ahora y hasta que haya solución segura, lo mejor es quedarte en 8.6 unas semanas mas.

          Un saludo

  7. manolo says

    seria interesante un articulo explicando como poder luchar contra los spams en la versión 8.7 , al haber esta desactivado de dspam

    un saludo

  8. Gustavo says

    Hola Jorge!! Excelente articulo, voy a ver si en estos días actualizo a zimbra 8.7. Te quería consultar Jorge como puedo hacer para que no me llegue spam desde mi cuenta?? Porque al abrir mi cuenta de correo me llegan spam con mi dirección de mail.

    Saludos..

  9. Jose Vte. says

    Hola Jorge.

    Ya no se puede usar DSPAM en la version 8.7 ahora que antispan seria conveniente activar de serie a zimbra o alguno recomendado ya que sinun antispan llega mucho correo basura.

  10. Antonio Sifontes says

    Buenas

    Como pudiera realizar un backup de mi zimbra sin bajar el servicio y tener mis bases de datos de ldap y MySql con buena integridad.

  11. Fabi Soares Schmidt says

    Hola Jorge ! Congratulations for another great article.

    I have updated an enviroment from Zimbra 8.6 NE to 8.7 NE on Red Hat 7 and I had some struggles:

    – The system runs behind a proxy and the script which checks the license is written in perl and do not read the SO proxy variable, so I need to use “–skip-activation-check”;
    – I had to change the config “zimbra_require_interprocesses_security” to 0, because the services failed trying to use TLS;

    Best regards.

  12. Mario Garcia says

    Hola Jorge

    Esta version 8.7 ya esta estable, o es aconsejable esperar un poco mas para hacer el upgrade!!!

    Saludos…

    • Jorge de la Cruz says

      Saludos Mario, creo que aunque las mejoras son muchas, es mejor esperar a 8.7.1, ya que hay ciertos bugs en el upgrade que pueden complicar mucho actualizar y generarnos muchas frustraciones, instalaciones de cero funcionan muy bien, pero es mejor esperar para el upgrade.

      Un saludo

  13. Daniel says

    Jorge, nuevamente muchas gracias por tu grandiosos Post y compartirla con todos los interesados en el tema.

    Me podrías aconsejar con el siguiente mensaje:

    Al realizar el upgrade de la 8.6 a 8.7 Collaboration, todo me fue bien, pero en la consola administrativa al revisar la cola de correo me da este error, y donde debe estar los números de la cola muestra en ves del número la palabra error:
    Mensaje: system failure: exception during auth {RemoteManager: mail.windsorplaza.com.sv->[email protected]:22} Código de error: service.FAILURE Method: [unknown] Detalles:soap:Receiver

    Antemano agradezco tu ayuda.

    • Jorge de la Cruz says

      Saludos Daniel,
      Seguiste estas ultimas mejoras y reiniciaste?
      zmprov mcf zimbraMtaCommandDirectory /opt/zimbra/common/sbin
      zmprov mcf zimbraMtaDaemonDirectory /opt/zimbra/common/libexec
      zmprov mcf zimbraMtaMailqPath /opt/zimbra/common/sbin/mailq
      zmprov mcf zimbraMtaManpageDirectory /opt/zimbra/common/share/man
      zmprov mcf zimbraMtaNewaliasesPath /opt/zimbra/common/sbin/newaliases
      zmprov mcf zimbraMtaSendmailPath /opt/zimbra/common/sbin/sendmail

      Si tenias DSPAM, tienes que desactivarlo
      zmprov ms `zmhostname` zimbraAmavisDSPAMEnabled FALSE
      zmlocalconfig -e amavis_dspam_enabled=false
      zmamavisdctl restart

  14. Ariel Ramos says

    Hola Jorge

    He intentado el upgrade, pero a diferencia de todos los comentarios aca, a mi me sucede otra cosa

    Cuando utilizo el zmproxyconfig para asignar los puertos del proxy, no me levanta el servicio de zmmailboxctl. He leido los logs, y aunque a esta hora no los tengo a mano, menciona que el puerto 7025 esta already bind, pero he revisado con netstat y no hay ningun servicio ocupando ese puerto.

    Como no funciona el mailbox, tampoco funciona la interfaz web ni el admin ni nada, asi que estoy “stuck” y no puedo ni empezar el upgrade,

    Envia mensajes como este:
    Zimbra server reserving server socket port=7025 bindaddr=null ssl=false
    Caused by: java.net.BindException: Address already in use

    Antes de ejecutar los comandos zmproxyconfig, todo funcionaba absolutamente perfecto. Estoy obligado a poner el proxy porque el 8.7 me lo pide de requerimiento para el upgrade.

    Alguna sugerercia? Llevo ya 2 dias sin encontrar una solucion precisa.

      • Ariel Ramos says

        Instale los RPMS de proxy y memcached (ya que no estaban instalados)

        Todo ok hasta aqui

        Luego ejecute lo siguiente

        ./libexec/zmproxyconfig -e -w -o -a 8080:80:8443:443 -x https -H `zmhostname`
        ./libexec/zmproxyconfig -e -m -o -i 7143:143:7993:993 -p 7110:110:7995:995 -H `zmhostname`
        zmprov ms `zmhostname` zimbraMailReferMode reverse-proxied
        zmprov ms `zmhostname` +zimbraServiceEnabled memcached
        zmprov ms `zmhostname` +zimbraServiceEnabled proxy
        zmcontrol restart

        Este era el port scan antes de ejecutar estos comandos:

        Other addresses for localhost (not scanned): 127.0.0.1
        Not shown: 984 closed ports
        PORT STATE SERVICE
        22/tcp open ssh
        25/tcp open smtp
        110/tcp open pop3
        111/tcp open rpcbind
        143/tcp open imap
        443/tcp open https
        465/tcp open smtps
        587/tcp open submission
        631/tcp open ipp
        993/tcp open imaps
        995/tcp open pop3s
        7025/tcp open vmsvc-2
        8080/tcp open http-proxy
        8443/tcp open https-alt
        10024/tcp open unknown
        10025/tcp open unknown

        Ya despues no habilitaba el puerto 7025 y no iniciaba el mailbox, y desencadena en que tampoco puedo entrar al webmail ni al admin

        Con zmproxyconfig luego deshabilite, o mas bien, hice rollback a la configuracion de los puertos proxy y todo volvio a funcionar y levantaba los servicios

  15. Jose L. Garcia says

    ¿Alguno habeis intentado migrar de ubuntu 14 a 16 con Zimbra 8.7 instalado?
    Cuando lo intento, el proceso de migración (do-release-update) me desinstala zimbra.

  16. Dani says

    Buenas Jorge, solo escribo para ver si me puedes confirmar lo que me ha ocurrido tras el update a la 8.7

    Tras actualizar, haciendo comprobaciones de seguridad rutinarias, he notado que SI podia enviar mediante telnet 25 cualquier correo FAKE desde cualquier cuenta a traves del servidor. Cosa que antes del update no se permitia.
    Recordando tu post (securizando zimbra 2) he accedido al fichero: /opt/zimbra/conf/zmconfigd/smtpd_sender_restrictions.cf y cual es mi sorpresa, que ya no se encontraba la cadena “reject_sender_login_mismatch” en dicho fichero.

    Por lo que mi pregunta es, si tras la actualizacion (y me consta que se borran carpetas pues me aparecen enlaces simbolicos huerfanos en /opt/zimbra/xxxx ) es posible que algunas configuraciones personalizadas de los ficheros se sobreescriban por otras nuevas.

    Gracias y un saludo.

    • Jorge de la Cruz says

      Saludos Dani,
      Si, seguramente al ser una edicion sobre un fichero, al actualizar se borren, todo lo que se guarda en LDAP se queda, pero en este caso al ser una edición sobre fichero no se guarda.

      Que tal va todo en 8.7?

      Un saludo

      • Dani says

        Va mas o menos igual.

        En el aspecto antispam si que se observa una gran mejora a priori, y sin tocar ningun tipo de configuracion. A ver con el tiempo.
        Feliz.

  17. Hasan says

    Hola Jorge, tengo el siguiente problema con el comando ( /opt/zimbra/bin/zmcertmgr zmcertmgr deploycrt self -new ) :

    root@mail2:/home/user/# /opt/zimbra/bin/zmcertmgr createca -new
    ** Creating /opt/zimbra/ssl/zimbra/ca/zmssl.cnf…done
    ** Creating CA private key /opt/zimbra/ssl/zimbra/ca/ca.key…done.

    root@mail2:/home/user/zimbra/zcs-patch-8.6.0_GA_1200# /opt/zimbra/bin/zmcertmgr deployca
    ** Importing CA /opt/zimbra/ssl/zimbra/ca/ca.pem into CACERTS…done.
    ** Saving global config key zimbraCertAuthorityCertSelfSigned…done.
    ** Saving global config key zimbraCertAuthorityKeySelfSigned…done.
    ** Copying CA to /opt/zimbra/conf/ca…done.

    root@mail2:/home/user/# /opt/zimbra/bin/zmcertmgr deploycrt self -new
    Can’t deploy cert for -new. Unknown service.

    ¿Por que sale ese fallo?

    Saludos y gracias.

    • Pau says

      Hola Jorge,

      bastantes problemas está dando este upgrade de versión. Estoy pasando de 8.0 a 8.7:

      He seguido los pasos para modificar el hostname y la ip ya que es un clon del entorno de producción, validado que arranca antes de proceder al upgrade. He seguido las instrucciones de esta guía reemplazando el certificado comercial por el autofirmado. Aun así tras ejecutar:

      ./install.sh –force-upgrade –skip-activation-check –skip-upgrade-check

      Checking ldap status…not running.
      Checking ldap status…not running.
      Starting ldap…failed with exit code: 256.
      57ff7a99 backend_startup_one (type=mdb, suffix=””): bi_db_open failed! (80)

      He revertido ya unas cuantas veces el snapshot previo al cambio de certificado y tatado de segir los pasos nuevamente pero siempre acabo en este estado.

      ¿tienes idea de qué me está pasando?

      Un saludo y muchas gracias por tu ayuda!

  18. Carlos Andres says

    Buenas Tardes,

    Estimado Jorge

    Al realizar el ./install llega un punto en el que el proceso se rompe y queda incompleto:

    Stopping mysql…done.
    Updating from 8.6.1_GA
    Updating from 8.7.0_BETA1
    Updating mailboxd_java_options to remove deprecated PermSize and MaxPermSize java options.
    Updating from 8.7.0_BETA2
    Updating from 8.7.0_RC1
    Can’t call method “get_value” on an undefined value at /opt/zimbra/libexec/zmupgrade.pm line 2261.

    Cómo lo podría solucionar.

    Excelente todo lo que haces, agradecido.

      • Carlos Andres says

        Hola Jorge,

        Es que efectivamente lo estoy haciendo desde la 8.6 a la 8.7.1:

        Checking ldap status…already running.
        /opt/zimbra/bin/zmjava: line 56: /opt/zimbra/java/bin/java: No such file or directory
        /opt/zimbra/bin/zmjava: line 56: exec: /opt/zimbra/java/bin/java: cannot execute: No such file or directory
        Stopping mysql…done.
        Updating from 8.6.1_GA
        Updating from 8.7.0_BETA1
        Updating mailboxd_java_options to remove deprecated PermSize and MaxPermSize java options.
        Updating from 8.7.0_BETA2
        Updating from 8.7.0_RC1
        Can’t call method “get_value” on an undefined value at /opt/zimbra/libexec/zmupgrade.pm line 2261.

        desde:

        zcs-8.6.0_GA_1153.RHEL6_64.20141215151155 –> Instalado
        a
        zcs-8.7.1_GA_1670.RHEL6_64.20161025035141

        Pero me genera esos errores, que más puedo hacer??

        Gracias por tu colaboración.

        • Carlos Andres says

          Pensé tenía que ver algo con que el usuario root no reconocía las variables de entorno del java, aún así lo configuré pero siguió con el mismo error al momento de realizar el upgrade.

          No tendría problemas en pasar de la 8.6.0 a la 8.7.1 de forma directa? o es recomendable de la 8.6.0 >> 8.7.0 >> 8.7.1?

          Otra pregunta adicional.

          La versión que indicas en el post es la NETWORK
          zcs-NETWORK-8.7.0_GA_1659.UBUNTU14_64.20160628202904.tgz

          Cuando en su momento intenté actualizar a esta, me generaba un error de licencia, esta versión es de pago?

          ERROR: The ZCS Network upgrade requires a license to be located in
          /opt/zimbra/conf/ZCSLicense.xml or a license previously installed.
          The upgrade will not continue without a license.

          Your system has not been modified.

          New customers wanting to purchase or obtain a trial license
          should contact Zimbra sales. Contact information for Zimbra is
          located at http://www.zimbra.com/about/contact_us.html
          Existing customers can obtain an updated license file via the
          Zimbra Support page located at http://www.zimbra.com/support.

          Gracias.

  19. JAVIER GARCIA ALARCÓN says

    Hola
    Actualizado en un Centos 6 sin ningún problema. Costó un poquito activar la autenticación de dos factores pero nada digno de mención… un zmcontrol restart solucionó un error que daba.
    Ahora debo ponerme a investigar el cómo meter un logo para algunos clientes y su propio certificado bajo su url tipo webmail.dominiocliente.com para que tengan “su” propio sistema de correo…
    Saludos y gracias por el post Jorge.

  20. Perla Viera says

    Hola Jorge,

    Una consultatalvez un poco tonta, qué efecto tiene en mis usuarios el activar el proxy?
    La mayoría de mis usuarios consulta su correo en outlook o aplicaciones de su celular y yo administro el servidor single-server.
    Estoy tratando de hacer el update, pero primero esto instalando el proyxy y el memcached, sólo que no logro que el outlook ni las aplicaciones móviles conecten con mis servicios, algo que sugieras que debo revisar y/o hacer?
    seguí las instrucciones de esta página para activar el proxy y el memcached.
    Saludos

    • Jorge de la Cruz says

      Saludos Perla,
      Sigue estos pasos:
      ./libexec/zmproxyconfig -e -w -o -a 8080:80:8443:443 -x https -H `zmhostname`
      ./libexec/zmproxyconfig -e -m -o -i 7143:143:7993:993 -p 7110:110:7995:995 -H `zmhostname`
      zmprov ms `zmhostname` zimbraMailReferMode reverse-proxied
      zmprov ms `zmhostname` zimbraReverseProxyMailMode https
      zmprov md tudominio.com zimbraPublicServiceProtocol https
      zmprov md tudominio.com zimbraPublicServicePort 443
      zmcontrol restart

      Una vez hagas eso pegame el resultado de
      lsof -i :443
      Debe de funcionar
      Un saludo

      • Perla Viera says

        Hola,

        Ya corrí los comandos, pero sigo teniendo errores con las aplicaciones, sólo me funciona checar el correo directo desde web.

        Sobre lo que solicitaste, aquí está el resultado del comando:
        nginx 2753 zimbra 10u IPv4 274671531 0t0 TCP *:https (LISTEN)
        nginx 2754 zimbra 10u IPv4 274671531 0t0 TCP *:https (LISTEN)
        nginx 2755 zimbra 10u IPv4 274671531 0t0 TCP *:https (LISTEN)
        nginx 2756 zimbra 10u IPv4 274671531 0t0 TCP *:https (LISTEN)

        No tendra algo que ver que mi servidor es host.midominio y para acceder a él (por configuraciones del administrador de red) solo se puede hacer a través de correo.dominio (que es como el alias de host.midominio)?

      • Perla Viera says

        Hola,

        Ya ejecute los comandos y sigo con el mismo problema.

        El resultado que me regresó el último comando fue:
        nginx 2753 zimbra 10u IPv4 274671531 0t0 TCP *:https (LISTEN)
        nginx 2754 zimbra 10u IPv4 274671531 0t0 TCP *:https (LISTEN)
        nginx 2755 zimbra 10u IPv4 274671531 0t0 TCP *:https (LISTEN)
        nginx 2756 zimbra 10u IPv4 274671531 0t0 TCP *:https (LISTEN)

        Pero noto que si cambio en el outlook el puerto de escucha del servicio pop de 110 a 7110 si se conecta, esto significa que tendré que cambiar el puerto de todas mis cuentas ya instaladas?
        Si mis usuarios usan un alias para acceder a mi servidor (correo.midominio.com) en lugar de mi hostname directamente (porque no es accesible desde fuera de mi red por configuraciones del administrador de red, ellos usan correo.midominio.com) esto tiene algo que ver?

      • Perla Viera says

        Hola Jorge,

        Volví a correr los comandos y cheque de nuevo las cuentas y lo que ocurre es que no me conectan si están en POP o en IMAP, tienen que conectarse como POP SSL o IMAP SSL. Esto quiere decir que con el proxy ya no podré usar las conexiones sin SSL? o existe alguna manera de que se sigan usando.

        Ahorita mis jefes me pidieron desintalar los servicios y esperar antes de intentar actualizar de nuevo, por lo que estaré investigando al respecto.

        Muchas gracias por tu ayuda, saludos desde México.

        • Jorge de la Cruz says

          Saludos Perla,
          Para usar http, no lo recomiendo, es texto plano y la comunicación puede ser interceptada, usuario y password incluido!!
          zmprov ms `zmhostname` zimbraReverseProxyMailMode both
          ./libexec/zmproxyconfig -e -w -o -a 8080:80:8443:443 -x both -H `zmhostname`

          Un saludo

          • Perla Viera says

            Gracias Jorge, lo comentaré con mis jefes, ya que parte de la idea de actualizar es por las mejoras en seguridad.
            Saludos

          • Perla Viera says

            Jorge sólo quiero agradecerte mucho el apoyo que brindas con tus publicaciones y resolviendo dudas, ahorita ya tengo el zimbra 8.7.1 Open Source corriendo sin problemas y con todos mis usuarios conectándose a través de protocolos seguros. En próximos días voy a ir agregando gradualmente configuraciones al postscreen para ir fortaleciendo la seguridad.

            De nuevo, muchas gracias y saludos desde México.

        • Javier garcía says

          Por cierto, si que hay una cuestión que acabo de detectar y es que si tienes personalizado con tu logo el interface web, tanto el webmail como el panel de administración, dicha personalización se pierde y hay que volver a ajustarla.
          Saludos

  21. Mario Garcia says

    Buenos días Jorge

    He estado al pendiente de las actualizaciones de Zimbra, recientemente vi que ya se encuentra disponible la versión 8.7.1, que novedades trae esta versión, y que recomiendas de hacer un upgrade o realizar una instalación limpia de esta versión.

    Saludos…

  22. Esteban says

    Estimado Jorge.
    Al ejecutar el script me tira el error que te voy a copiar a continuación, el cual estuve buscando en internet y no hay mucha información al respecto.

    Error:
    Use Zimbra’s package repository [Y] y
    Importing Zimbra GPG key
    ERROR: Unable to retrive Zimbra GPG key for package validation
    Please fix system to allow normal package installation before proceeding

    Desde ya muchas gracias por la colaboración
    Saludos cordiales.
    Esteban A

    • Gianluca says

      Esteban,

      The Zimbra GPG key is served over a HTTPS connection. It’s very common on updated CentOS that you are not actually using the update CAs bundle.

      Look at your /etc/pki/tls/certs/ folder, you should have a ca-bundle.crt.rpmnew; this is the updated CAs’ bundle, but it’s not currently used by your system.

      You should move it over your ca-bundle.crt (backup it up first!). After the you should be able proceed with the Zimbra installation.

  23. Miguel says

    un gran aporte una vez mas estimado.
    un dato extra para aquellos que revisen la presente guia y quieran llevar zimbra de la version 8.6 a la ultima q ha salido 8.7.6.
    en la cual podria salirles el siguiente error:

    No package zimbra-memcached- available.
    Error: Nothing to do

    que es un error al descargar el memcached de zimbra.
    como veran es porque esta ingresando el nombre equivocado y el repositorio no lo reconoce. Para ello se debe editar el siguiente archivo:

    ./util/modules/packages.sh
    (porfavor sacar un backup de archivo por si se equivocan)
    y buscar ls siguiente linea:
    yum downgrade –downloadonly –assumeyes zimbra-memcached-$MEMCACHEDVER >> $LOGFILE 2>&1

    misma que deben cambiarpor lo siguiente:
    yum downgrade –downloadonly –assumeyes zimbra-memcached >> $LOGFILE 2>&1

    y listo con ello la actualizacion fluira de forma normal.

      • miguel says

        Muchas gracias aun no habia revisado esta version de Zimbra 8.7.7. exactamente acabo de corroborarlo y efectivamente el error que mensionaba en la version 8.7.6 ya no exite, muchas gracias por tu pronta respuesta.
        Saludos

  24. cesar says

    A mi me arroja este error :
    Unable to start TLS: SSL connect attempt failed error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed when connecting to ldap master.

  25. Carlos says

    Buenas Jorge, tengo el zimbra 8.6 P8 y estoy pensando pasarme al 8.7.x, la cuestión es que tengo el zimlet Zextras Chat. Me recomiendas que lo desinstale antes de realizar el upgrade? o lo hago normalmente?

    Desde ya muchas gracias y saludos desde Paraguay!

    • Jorge de la Cruz says

      Saludos Carlos,
      Creo que el Chat que viene con Zimbra es mas moderno y mejor acabado, yo lo desinstalaria antes de proceder a la instalación de Zimbra 8.7.x

      Un saludo!

      • Carlos Benitez says

        Jorge! solo pasaba para darte las gracias! Gracias a tu tutorial pude actualizarme tranquilamente al Zimbra 8.7 sin ningún tipo de problemas. Deberías tener algún tipo de monumento en unos años más! jajajaja Nos salvas la vida siempre!
        Otra vez muchas gracias por tus increíbles aportes!

        Un saludo!

  26. Giovanni Arias says

    Hola,

    Al iniciar le upgrade me solicito actualizar el ubuntu de la version 14 a la 16 y al realizarlo el zimbra no carga y al realizar el upgrade sale este errror y no se como resolverlo, le agradezco su valiosa ayuda:

    ./install.sh

    Operations logged to /tmp/install.log.nSeS7Wgn
    Checking for existing installation…
    zimbra-chat…NOT FOUND
    zimbra-drive…NOT FOUND
    zimbra-suiteplus…NOT FOUND
    zimbra-ldap…FOUND zimbra-ldap-8.6.0.GA.1153.UBUNTU14.64
    zimbra-logger…FOUND zimbra-logger-8.6.0.GA.1153.UBUNTU14.64
    zimbra-mta…FOUND zimbra-mta-8.6.0.GA.1153.UBUNTU14.64
    zimbra-dnscache…NOT FOUND
    zimbra-snmp…FOUND zimbra-snmp-8.6.0.GA.1153.UBUNTU14.64
    zimbra-store…FOUND zimbra-store-8.6.0.GA.1153.UBUNTU14.64
    zimbra-apache…FOUND zimbra-apache-8.6.0.GA.1153.UBUNTU14.64
    zimbra-spell…FOUND zimbra-spell-8.6.0.GA.1153.UBUNTU14.64
    zimbra-convertd…NOT FOUND
    zimbra-memcached…FOUND zimbra-memcached-8.6.0.GA.1153.UBUNTU14.64
    zimbra-proxy…FOUND zimbra-proxy-8.6.0.GA.1153.UBUNTU14.64
    zimbra-archiving…NOT FOUND
    zimbra-core…FOUND zimbra-core-8.6.0.GA.1153.UBUNTU14.64
    ZCS upgrade from 8.6.0 to 8.7.11 will be performed.
    Checking for existing proxy service in your environment
    Error: Unable to contact the LDAP server.
    root@mail:~/zcs-8.7.11_GA_1854.UBUNTU16_64.20170531151956# su zimbra

    • Jorge de la Cruz says

      Saludos Giovanni,
      Puedes intentar lanzar el instalador así ./install.sh –force-upgrade

      Dinos a ver, a su vez mira el log en /tmp/install.log.nSeS7Wgn a ver si te da mas información

      un saludo

  27. Giovanni Arias says

    Revisando no esta el archivo de configuración del zmcontrol y al correrlo en la ruta /opt/zimbra/bin/zmcontrol start
    Sale violación de segmento (`core` generado)

  28. Giovanni Arias says

    Gracias Jorge;

    Reinstale el ubuntu server y reinstale el zimbra 8.6, y levanto, luego volví a ejecutar el upgrade y funciono bien,
    La consulta es si se puede migrar ubuntu 14 a 16, seria solo de realizar el upgrade del ubuntu? o hay que reinstalar el zimbra para ubuntu 16?

    Gracias

    • Jorge de la Cruz says

      Saludos Giovanni,
      Hay un bug abierto ahora mismo de cuando subes de ubuntu 14 a ubuntu 16, no siempre sucede, pero se pueden perder datos. Por lo que te recomiendo leer los foros de Zimbra sobre ello.

      Un saludo

  29. Dayana Gonzalez says

    Hola, realice el upgrade de versión 8.7 a 8.7.11, pero al tratar de habilitar el chat, me genera el siguiente error

    zmzimletctl enable /opt/zimbra/zimlets/com_zextras_chat_open.zip
    [] INFO: Enabling Zimlet /opt/zimbra/zimlets/com_zextras_chat_open.zip
    com.zimbra.cs.zimlet.ZimletException: Cannot enable Zimlet /opt/zimbra/zimlets/com_zextras_chat_open.zip
    at com.zimbra.cs.zimlet.ZimletException.CANNOT_ENABLE(ZimletException.java:88)
    at com.zimbra.cs.zimlet.ZimletUtil.setZimletEnable(ZimletUtil.java:914)
    at com.zimbra.cs.zimlet.ZimletUtil.enableZimlet(ZimletUtil.java:930)
    at com.zimbra.cs.zimlet.ZimletUtil.dispatch(ZimletUtil.java:1943)
    at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.java:2007)
    Caused by: com.zimbra.cs.account.AccountServiceException: no such zimlet: /opt/zimbra/zimlets/com_zextras_chat_open.zip
    ExceptionId:main:1512959384635:fe4e7c6964435a50
    Code:account.NO_SUCH_ZIMLET
    at com.zimbra.cs.account.AccountServiceException.NO_SUCH_ZIMLET(AccountServiceException.java:267)
    at com.zimbra.cs.zimlet.ZimletUtil.setZimletEnable(ZimletUtil.java:907)
    … 3 more
    [] ERROR: Error
    com.zimbra.cs.zimlet.ZimletException: Cannot enable Zimlet /opt/zimbra/zimlets/com_zextras_chat_open.zip
    at com.zimbra.cs.zimlet.ZimletException.CANNOT_ENABLE(ZimletException.java:88)
    at com.zimbra.cs.zimlet.ZimletUtil.setZimletEnable(ZimletUtil.java:914)
    at com.zimbra.cs.zimlet.ZimletUtil.enableZimlet(ZimletUtil.java:930)
    at com.zimbra.cs.zimlet.ZimletUtil.dispatch(ZimletUtil.java:1943)
    at com.zimbra.cs.zimlet.ZimletUtil.main(ZimletUtil.java:2007)
    Caused by: com.zimbra.cs.account.AccountServiceException: no such zimlet: /opt/zimbra/zimlets/com_zextras_chat_open.zip
    ExceptionId:main:1512959384635:fe4e7c6964435a50
    Code:account.NO_SUCH_ZIMLET
    at com.zimbra.cs.account.AccountServiceException.NO_SUCH_ZIMLET(AccountServiceException.java:267)
    at com.zimbra.cs.zimlet.ZimletUtil.setZimletEnable(ZimletUtil.java:907)
    … 3 more

    • Jorge de la Cruz says

      Saludos, com_zextras_chat_open.zip no es ningun chat que yo conozca incluido en la version de Zimbra, el que Zimbra trae es /opt/zimbra/zimlets/com_zextras_chat_open.zip que se autoinstala, revisa a ver.

      Un saludo

      • Dayana Gonzalez says

        Hola Jorge, gracias por la respuesta, entonces me genera un poco la duda, como se activa el chat de Zimbra luego de la actualización realizada. yo realize el proceso de actualizar de 8.7 a 8.7.11, pero al abrir el correo no me aparece la ventana de chat.

        • Jorge de la Cruz says

          Saludos Dayana,
          Deberia de venir incluido, revisa que tienes el zimlet habilitado en la parte de admin, tambien puedes hacer un apt-get install zimbra-chat si tienes ubuntu, o yum install zimbra-chat, a ver que te sale.

          • Dayana Gonzalez says

            Hola Jorge,
            Cuando ejecuto el comando, me aparece lo siguiente
            zimbra-chat is already the newest version.
            y revisando en el admin, el Zimlet de chat aparece en el estado Activado.
            Pero sigue sin aparecer el chat. No se que pueda ser?
            Gracias

  30. Jacob Reyes says

    Hola Jorge, Buen aporte… actualicé mi sistema y el mta sale que postfix is not running utilizo Centos 7, por si acaso tendrás alguna herramienta para hacer backup de la base de datos y restaurar en una instalación limpia?

    • Jorge de la Cruz says

      Saludos Jacob, si subiste de 8.6 a 8.7, lanza estos comandos a ver si te ayudan:
      zmprov mcf zimbraMtaCommandDirectory /opt/zimbra/common/sbin
      zmprov mcf zimbraMtaDaemonDirectory /opt/zimbra/common/libexec
      zmprov mcf zimbraMtaMailqPath /opt/zimbra/common/sbin/mailq
      zmprov mcf zimbraMtaManpageDirectory /opt/zimbra/common/share/man
      zmprov mcf zimbraMtaNewaliasesPath /opt/zimbra/common/sbin/newaliases
      zmprov mcf zimbraMtaSendmailPath /opt/zimbra/common/sbin/sendmail
      zmcontrol restart

      Un saludo

  31. Leonardo says

    Hola Jorge, muchas gracias por el post. Te consulto ya que he adquirido una licencia de ZNE para actualizar nuestro servidor actual ZCS 8.6. El problema surge en que no es posible actualizar el sistema operativo ubuntu 14.0.4 a 16.04. Existe alguna herramienta de migración para poder migrar el servidor en vez de actualizarlo. Muchas gracias.

  32. Emiliano says

    Buenas tardes Jorge, cómo estás?.
    Tengo que aplicar un upgrade de Zimbra 8.6 a Zimbra 8.8 (nuevo release). Cuales serían tus recomendaciones para el procedimiento de upgrade?. Es aplicable éste mismo procedimiento?.
    Gracias,
    Saludos!

  33. flavio says

    Jorge, genio, antes que nada agradecerte todos los post realizados sobre zimbra, he aprendido muchisimo con tus tutos, y es por eso que acudo a consultarte,

    Tengo un problema al intentar actualizar mi version de zimbra 8.5 GA, me da el siguiente error:
    Tienes idea donde puede atacar este problema?

    mi correo es [email protected] identico ID de Skype, muchas gracias.

    [root@zimbrafielex zcs-8.8.15_GA_3869.RHEL6_64.20190918004220]# ./install.sh

    Operations logged to /tmp/install.log.dw1F3vcU
    Checking for existing installation…
    zimbra-drive…NOT FOUND
    zimbra-imapd…NOT FOUND
    zimbra-patch…NOT FOUND
    zimbra-mta-patch…NOT FOUND
    zimbra-proxy-patch…NOT FOUND
    zimbra-license-tools…NOT FOUND
    zimbra-license-extension…NOT FOUND
    zimbra-network-store…NOT FOUND
    zimbra-network-modules-ng…NOT FOUND
    zimbra-chat…NOT FOUND
    zimbra-talk…NOT FOUND
    zimbra-ldap…FOUND zimbra-ldap-8.5.0_GA_3042
    zimbra-logger…FOUND zimbra-logger-8.5.0_GA_3042
    zimbra-mta…FOUND zimbra-mta-8.5.0_GA_3042
    zimbra-dnscache…FOUND zimbra-dnscache-8.5.0_GA_3042
    zimbra-snmp…FOUND zimbra-snmp-8.5.0_GA_3042
    zimbra-store…FOUND zimbra-store-8.5.0_GA_3042
    zimbra-apache…FOUND zimbra-apache-8.5.0_GA_3042
    zimbra-spell…FOUND zimbra-spell-8.5.0_GA_3042
    zimbra-convertd…NOT FOUND
    zimbra-memcached…FOUND zimbra-memcached-8.5.0_GA_3042
    zimbra-proxy…FOUND zimbra-proxy-8.5.0_GA_3042
    zimbra-archiving…NOT FOUND
    zimbra-core…FOUND zimbra-core-8.5.0_GA_3042
    ZCS upgrade from 8.5.0 to 8.8.15 will be performed.
    Checking for existing proxy service in your environment
    Checking for existing memcached service in your environment
    Validating ldap configuration
    Error: Unable to create a successful TLS connection to the ldap masters.
    Fix cert configuration prior to upgrading.

  34. Fede says

    Buenas, estoy migrando cuentas de zimbra 7.1 a 8,8 con el wizard de importacion x ldap pero todas la cuentas migradas quedan con un asterisco rojo y dicen “esta cuenta utliza el transporte de correo externo” e intente cambiarlo x lmtp:midominio:7025 pero igualmente no me funciona, alguna idea que puede ser? para cambiar el mailtransport utilice zmprov ma cuenta zimbramailtransport lmtp:midominio:7025 gracias!

  35. Fede says

    Saludos, Muchas gracias Jorge por tu respuesta! Estuve viendo zextras, hay que instalarlo en ambas versiones verdad? y migrar haciend backup en el 7 y levantarlo en el 8 ? o se puede hacer por “red” sin bajar y subir archivos de backup? gracias nuevamente.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.